Scene Setup

I started a new project and built a basic PUN networking scene (just a character on a floor) and everything works until I Run the game and click to go from the menu scene to the game scene and this error appears

Error: The scene object ID 1 already exists. This can be corrected by running Scene Setup again on this scene.
Opsive.UltimateCharacterController.AddOns.Multiplayer.PhotonPun.Utility.PunUtility:RegisterSceneObjectIdentifier(ObjectIdentifier) (at C:/Users/chris/Unity Projects/RI_Alpha_Networking/Assets/Opsive/UltimateCharacterController/Add-Ons/Multiplayer/PhotonPUN/Scripts/Utility/PunUtility.cs:32)
Opsive.UltimateCharacterController.AddOns.Multiplayer.PhotonPun.Objects.SceneObjectIdentifier:Awake() (at C:/Users/chris/Unity Projects/RI_Alpha_Networking/Assets/Opsive/UltimateCharacterController/Add-Ons/Multiplayer/PhotonPUN/Scripts/Objects/SceneObjectIdentifier.cs:25)
UnityEngine.Object:Instantiate(GameObject, Vector3, Quaternion)
Opsive.UltimateCharacterController.AddOns.Multiplayer.PhotonPun.Game.SpawnManagerBase:SpawnPlayer(Player) (at C:/Users/chris/Unity Projects/RI_Alpha_Networking/Assets/Opsive/UltimateCharacterController/Add-Ons/Multiplayer/PhotonPUN/Scripts/Game/SpawnManagerBase.cs:140)
Opsive.UltimateCharacterController.AddOns.Multiplayer.PhotonPun.Game.SpawnManagerBase:Start() (at C:/Users/chris/Unity Projects/RI_Alpha_Networking/Assets/Opsive/UltimateCharacterController/Add-Ons/Multiplayer/PhotonPUN/Scripts/Game/SpawnManagerBase.cs:93)

I tried doing as it suggests and running the scene setup again and I have put in the Pun managers on my character again and everything and it still keeps coming back.

What should I do?


Staff member
For PUN related questions please post them in the PUN board.

After you ran the Scene Setup did you save the scene? If you do a search for SceneObjectIdentifier within your scene you could verify that there really is only one identifier with an ID of 1.
Thank you somehow the floor in the scene and the characters "Hips" were both set to 1 but I changed the floor to 0 and everything works fine.
Thank you again