How to make the first-person arms show?

Hi all,

So I have an ability that allows the player to push objects. The animation is playing perfectly fine in 3rd-person view, but the hands aren't playing the animation in first-person view. Because I also don't want the player to have a weapon equipped whilst he pushes an object, I disabled the slots in the ability settings. Even if I enable them and allow the player to carry a gun for example, the hands aren't playing the animation, but the entire body is. The hands aren't even getting enabled, which I'm assuming is something to do with a lack of an equipped item. Any suggestions would be much appreciated.
 
Last edited:
You could use a preset on the third person objects (arms) to force visible, that way you'll get the animated arms.
I have the third person objects using the InvisibleShadowcaster material, I'm unable to get the first person arms to show. There's only an option for AlwaysActive, but setting that to true doesn't seem to do anything.
 
Using force visible will swap the material for the original. Check the drive example how the arms are shown in first person view
The car demo uses the third person arms, not the first person arms. Is there a way to force the first person arms to show and play the animation?
 

FastSkillTeam

Active member
The car demo uses the third person arms, not the first person arms.
Exactly my point. Why do you need the first person arms to show, instead of third person? It's done that way as humanoid animations and or IK can be used on the humanoid third person character but not on the generic first person arms.
 
Top