[UFPS 2] Following setup guide leads to errors.

Janooba

New member
I've tried following the guide twice, once in text form, once in video form, and both times things have completely failed for me when trying to create a weapon and have it equipped.

Both times, the weapon doesn't actually spawn when I hit play. It looks like I have nothing equipped (despite the assault rifle being in the default loadout).
This last time though, following the video, I keep getting "Error: Category 752686780 cannot be found." 5 times when I hit play (as well as not actually having the item equipped)

The video guide doesn't say anything about item categories and the text guide glosses over it almost completely, other than saying I need to set the Assault Rifle to the (non-existant) weapons category. Am I missing other categories that the guide didn't tell me about?

This is really frustrating. The guides seem to gloss over a lot of tiny but critical details like this. For instance, it wasn't clear that I needed to drag in the "arms" models separately into the scene, and apply items to that, instead of the Character already in the scene.

Attached is the full Console log upon pressing Play.

Here's the stack trace of the category error:

Error: Category 752686780 cannot be found.
UnityEngine.Debug:LogError(Object)
Opsive.UltimateCharacterController.Inventory.ItemSetManager:CategoryIDToIndex(Int32) (at Assets/External/Opsive/UltimateCharacterController/Scripts/Inventory/ItemSetManager.cs:112)
Opsive.UltimateCharacterController.Character.Abilities.Items.ItemSetAbilityBase:Awake() (at Assets/External/Opsive/UltimateCharacterController/Scripts/Character/Abilities/Items/ItemSetAbilityBase.cs:41)
Opsive.UltimateCharacterController.Character.Abilities.Items.EquipUnequip:Awake() (at Assets/External/Opsive/UltimateCharacterController/Scripts/Character/Abilities/Items/EquipUnequip.cs:95)
Opsive.UltimateCharacterController.Character.UltimateCharacterLocomotion:Awake() (at Assets/External/Opsive/UltimateCharacterController/Scripts/Character/UltimateCharacterLocomotion.cs:272)
 

Attachments

  • Unity_2019-02-10_23-08-06.png
    Unity_2019-02-10_23-08-06.png
    59.8 KB · Views: 3

Justin

Administrator
Staff member

Janooba

New member
This is now the fourth time I've watched both videos, and followed them to a T. Everything is correctly referenced. The item itself, item collection, item set manager, and categories are all referenced correctly. I still get the same error. If you don't believe me, see for yourself:

https://gfycat.com/GratefulDangerousHippopotamus

I've followed each of the bullets in the equip-unequip page, and found no deviations.

https://gfycat.com/RealInfamousFunnelweaverspider

Here's another video of me playing, then hitting 1 to "swap" weapons.

I appreciate you looking into this, I suspect there is just a simple step that's missing in the tutorial. I implore you to try to follow along with the tutorials with only the UFPS2 installed, and see if your experienced eyes see a step I'm missing.
 

Justin

Administrator
Staff member
It looks like you created two different categories - make sure you only have one when you first get started. By default the "Items" category is created and you'll want to add all of the Item Types to that category. I would follow along with the videos exactly by naming everything the same and placing it in the same category just so you can ensure that you have the exact same setup. I also didn't create a new category so that is probably also why things are going wrong.

Beyond that you are probably getting the error because the EquipUnequip abilities aren't set to the Weapons category:

1549939525186.png
 

Janooba

New member
That's exactly the information I needed! :D

This is the part of the text guide that put me on the wrong track:

c7f1146a87.png


It specifies that I needed to set the new ItemType to "Weapons". Since Weapons didn't exist in the New item collection, I had to create it myself.

Anyways, now that this is cleared up, things seem to be working as expected. Thank you for your time!
 

Justin

Administrator
Staff member
Oops.. amazing how one word changes everything :) I just updated that documentation page to say items. Glad you got it working!
 

Janooba

New member
Thanks! It might also be worth making a quick mention of how the category is used in the EquipUnequip item ability as well. I would have never found that on my own (other than scowering the documentation)
 
Top