Swapping items breaks arm animation

armaan8014

New member
So when I have a pistol equipped, and then swap it out for another item, and then swap back to the pistol, the animation breaks (specifically the right hand's position) Any ideas what could cause this? I am not using Wait for animator event for any of these.

Here's a gif showing the issue:

Thanks
 

Andrew

Well-known member
Have you got any state presets modifying the position offset values on the FirstPersonPerspectiveItem?
 

armaan8014

New member
I'm sorry what are state presets/ where can I find them?

Interesting thing is that the position offset values do nothing for my character arms. I followed the tutorial and at the point I had to readjust the arm position using the offset, it did nothing. Instead I changed the position of the arms within my animations. I'm also using custom arms and mixamo animations on them.

So even modifying the position offset values wouldn't be the cause of this imo.
 

armaan8014

New member
Okay, I just looked into State presets and no - I'm not using those. Also the pistol animation is fine originally, it only breaks when switching from another weapon.

Also, it only seems to affect the right hand, not the left, even though I don't have them separated out.

Edit: I made a new character and the problem still persists.
 
Last edited:

armaan8014

New member
Also - my characters are generic, not humanoid (therefore no Unity IK) if that makes any difference, and if UCC references or tries to use IKs anywhere.
 
Last edited:

Andrew

Well-known member
Make sure that your animations, imported character model and animator controller all share the same avatar (preferably the one from your character model). You can set this on animations in their import settings under the "Rig" tab ("Copy From Other Avatar"). I'm not too familiar with generic rigs in specific but there shouldn't be any reason that would cause the issue of the position offset values not working.
 
Top