Player sticking to hills very bad

artmatv

New member
My player climbs the hills very raggedly, I have tried many parameters, but I can not achieve the desired result. Where should I look?
 

Andrew

Moderator
Staff member
A few things to try:

- Check the collider on the slope itself. If it's a complex mesh with a lot of tris, there might be bumps etc. that the character struggles to smoothly walk up. You generally want smooth, straight slopes as much as possible
- Try adding a frictionless physics material to the slope (and set the friction mode to "minimum")
- Try increasing the "Slope limit" on your UltimateCharacterLocomotion component (under "Physics")
 

artmatv

New member
A few things to try:

- Check the collider on the slope itself. If it's a complex mesh with a lot of tris, there might be bumps etc. that the character struggles to smoothly walk up. You generally want smooth, straight slopes as much as possible
- Try adding a frictionless physics material to the slope (and set the friction mode to "minimum")
- Try increasing the "Slope limit" on your UltimateCharacterLocomotion component (under "Physics")
I've tried climbing on the default unity plane with different physics material - the same result.
Slope limit is also set to 90
 

Andrew

Moderator
Staff member
In that case it could be an animation issue. Are you using root motion, and any custom animator/animations? You could try editing the Root Transform Position settings in your animation's import settings (find the walking animation FBX and go to the "Animation" tab in the inspector):

1631871166210.png

Specifically, you'll want to bake the root transform Y position into pose and probably use "Original" position.
 
Top