Opsive.Shared.Editor.UIElements.dll is broken in Unity 2022.2.0b16

dysleixc

New member
Hi, I'm currently receiving these errors when doing clean install on Unity 2022.2.0b16.

Redownloading/reimporting package doesn't do any better, and judging by the code I would assume that Opsive.Shared.Editor.UIElements.dll is causing the issues.

1669762944061.png
 

FastSkillTeam

Active member
Probably because your using a beta version of unity, no asset developers account for betas, as the changes are too rapid. Try using the recommended unity version.
 

dysleixc

New member
@FastSkillTeam that was my first thought, but what would the reason for these errors be anyway? The references that this library is missing are perfectly present in current UIElements setup.
 

FastSkillTeam

Active member
UI Elements likely had a change, and UIElementsModule doesn't contain PropertyField or MaskField any longer. Just a guess.
 

FastSkillTeam

Active member
Probably caused by compilation error on import. Not sure. Don't have a beta to test and don't ever intend to use anything but lts.
 

Justin

Administrator
Staff member

yupengfei

New member
This is a known issue:


Beta versions of Unity are not supported by the controller. I am hoping Unity will fix this before release but if not I will have a workaround.

Justin
Same error on 2022.1.23f1c1, it is not a beta version.
 
Last edited:

yupengfei

New member
This is a known issue:


Beta versions of Unity are not supported by the controller. I am hoping Unity will fix this before release but if not I will have a workaround.

Justin
And I tried 2021.3.15f1c1, it comes with error below
QQ截图20221207231930.png
 

Justin

Administrator
Staff member
2022.2.b16
2022.2 hasn't been released and 2022.2b16 indicates it's a beta version. As soon as 2022.2 is released I'll upload the workaround if it is necessary.

And I tried 2021.3.15f1c1, it comes with error below
A different version has been submitted which works with 2021.3 versus 2022.1. If you download again from the package manager it will grab the correct version.
 

yupengfei

New member
2022.2 hasn't been released and 2022.2b16 indicates it's a beta version. As soon as 2022.2 is released I'll upload the workaround if it is necessary.


A different version has been submitted which works with 2021.3 versus 2022.1. If you download again from the package manager it will grab the correct version.
Thank you, I tried 2022.1.23f1c1 again and it works!
 

Fenda

Member
2022.2 hasn't been released and 2022.2b16 indicates it's a beta version. As soon as 2022.2 is released I'll upload the workaround if it is necessary.


A different version has been submitted which works with 2021.3 versus 2022.1. If you download again from the package manager it will grab the correct version.

Hey Justin. Is the workaround something you can share until the beta becomes LTS? I've got a branch going to migrate to v3 and it would be nice to continue working on that but currently we're blocked by this error. We've been on 2022.2 beta for several months now.
 

Justin

Administrator
Staff member
Hey Justin. Is the workaround something you can share until the beta becomes LTS? I've got a branch going to migrate to v3 and it would be nice to continue working on that but currently we're blocked by this error. We've been on 2022.2 beta for several months now.
We are not able to support beta software due to errors like this. I am still going back and forth with the Unity developer on this bug so do not have a proper workaround yet.
 

dysleixc

New member
The 2022.2 has been released today, and these issues still exist there. When could we expect a fix or a workaround?
 

EVG

Member
Updated the inventory system and there seems to be no errors. But a new one appeared in the SetupManager component on line 461.
 
Top