Not working on Mobile


New member
I'm using a samsung Note Ultra 20, my game works fine until I add UCC. I have tested this multiple times now. I have gone down to the most basic setup and just added the First Person Controller to the scene with no character or any other items, just the defaults and then it breaks again. Then I remove the controller and the app works again on mobile.
What specifically doesn't work? What errors are you getting?

I have tested it on Android so I know that it does build and run correctly on that platform.
2023/01/16 14:12:15.351 20430 20529 Error Unity The file '.../base.apk/assets/bin/Data/sharedassets0.assets' is corrupted! Remove it and launch unity again!
So strange, If I remove the controller it works, If I add the most basic FPS controller it crashes and closes the app. Any idea? I can't find more debugging info that the above
I've come across that error before and it's a pain to debug since there isn't one cause. It has existed for awhile:

For me it ended up being an invalid reference. One of the objects that are serialized with [SerializedReference] contained a reference to an object that wasn't being included in the build. I wish that the error message gave more details so it's easier to track down the cause.
I've just a setup a brand new project and it does exactly the same thing. I've only added URP, UCC and Rewired to the project. I think this is a UCC issue

Below is a video with a demo on a brand new project
Have you tried a different version of Unity? I just tested version 3.0.5 of the controller with Unity 2022.2 and it worked without an issue on a Pixel 7. You can download the apk from this page. It makes me think that it's something specific to the Unity version (or device?) because I haven't gotten any other reports from this and late last year I was debugging a touch issue on Android. You can see it working for this user in this post.
I'm using Unity 2021.3.16f1 - I've downloaded the apk and it works fine, however its not the Rewired version. I've figured out that if I add UCC and Rewired to my scene without connecting them together it works fine. The moment I add Rewired Input from the Shared Integrations folder then it breaks.
Have you posted this question to the Rewired developer? Rewired is closer to the hardware than the character controller is so it may be somehow related to that. The RewiredInput component is just a lightweight component that interfaces with Rewired.
I have figured it out - its a UCC Integration component. Using "UniversalRP.unitypackage" from the Integrations page for UCC - I found that if I delete the Rewired Input Manager.prefab after adding it to my scene then it works fine, and also delete the "UIS" folder. I've tested this multiple twice, its definitely that integration package that is causing the problem
So there are four assets listed:


When you say that it's the integration package what integration package are you referring to?
I recommend getting in contact with the Rewired developer to see if there is anything that needs to be done for Android support. The RewiredInput component really doesn't do anything besides interface with Rewired. It would not be causing the corruption issue.