Item shows in inspector but not in-game UI

Sangemdoko

Moderator
Staff member
Hi @zooooot

As I said in Discord this is not enough information to go on with.
There are many reasons this could happen, Item Filters, Item Restrictions, bad setup, etc...

Please give us more information:
Are you using the UCC with UIS? Did you download the integration? Did you follow the documentation to convert a UCC character to UCC/UIS bridge?
What type of item isn't showing, is it mutable/immutable, unique/common, are you using special ItemCategories?
Does the Item disappear from the Item Collection at runtime?
Do you have restrictions on your inventory?
What type of Inventory UI are you using?
What version of are you using (make sure to check in our Editor, not the package manager)?
etc...

Also send us screenshots, or even make a video and share it here using https://streamable.com/
If you are getting any errors or warnings make sure to send us the full error/warning stack.
 

Sangemdoko

Moderator
Staff member
This error means that there are no ItemSets for shield 2.
So the system does not know how that item should be equipped and where.

You have two choices:
  1. make a new Item Set in the InventoryItemSetManager and add the shield2 item to it
  2. Make the shield 1 that works into a parent of shield 2 in the Editor
PS: We are looking into improving this in the future such that the system can create ItemSets dynamically when needed
 

Sangemdoko

Moderator
Staff member
You have set the shield in both slot 0 and 1 in the same Item Set, meaning you only allow dual wield shields.

You should only assign slot 1 if you plan to equip shields in the left hand.
Please read more about Item Sets in the documentation

Refer to the integration demo to see how the character is set there
 

zooooot

New member
You have set the shield in both slot 0 and 1 in the same Item Set, meaning you only allow dual wield shields.

You should only assign slot 1 if you plan to equip shields in the left hand.
Please read more about Item Sets in the documentation

Refer to the integration demo to see how the character is set there
So even with that, it throws the error that it can't find the item set.
 

Sangemdoko

Moderator
Staff member
Does the integration demo return the same error?
If so perhaps you have an outdated Integration, UCC or UIS package.

If the error is specific to your scene there must be something that is not correctly set up.
Compare your shield with the one from the demo.
Perhaps your Shield 2 Definition does not inherit the correct Item Category, the ItemObject prefab is not set correctly or maybe if you are using a pickup, it isn't setup correctly. Try comparing them side by side.

Also compare your character with the demo character.
 
Top