Hang Ledge Transfer Animation triggers twice

HU$H

New member
Hello, I've been trying to get my hang ability setup right for the last few days and for some reason it triggers the animation twice? I took a video with the animator open to the hang animations so you can see whats happening there. Any suggestion? I feel like it may be a state somewhere but I've copied everything I could find from the demo scene and I still cant seem to get it working. I have tried many key combo's to see if it was something I was trigging with my keyboard or mouse but still no clues there.

Here is a link to the video example with the animator and its parameters visible, as well as the hang ability in the inspector


and an image of my Locomotion states
Screen Shot 2021-01-18 at 2.31.02 PM.png
 

Justin

Administrator
Staff member
Did you replace the animations or animation events? It looks like the transfer complete event didn't get sent the first time.

Beyond that, are you able to reproduce it within the demo scene?
 

HU$H

New member
No I have not changed the animation everything is stock right now from the example package accept for my character prefab from the asset store. Opening the readonly TransferLeft animation I do not see an animation event. Which is weird, I would think it would be required to end the animation and would continue indefinitely without it but it only plays twice.

I can reproduce it in the demo scene if I import my character into it.

Screen Shot 2021-01-28 at 12.33.38 PM.png
 
Last edited:

Justin

Administrator
Staff member
Is the event being sent? Maybe with your new character the timings are a bit different so the animation event is never sent.
 

HU$H

New member
I'm assuming that the animation event that says to "stop the transfer animation" exists somewhere, provided that the opsive add-on manager adds that with the animations. If there is another way for me to find out besides the video I sent you (monitoring the parameter changes) I'd love to know about that, but the animations themselves show no animation events on the animation timeline for Nolan or for my character as shown in the image of my previous post. I'm still trying to get the "signal flow" as you would say in audio, I don't know where you've programmed these events if they are not setup on the animation timeline or in the ability settings. Still looking for the "source" of my animation triggers here, any documentation recommendations are always appreciated, I've read through them but I've taken on a lot here so I may have missed something.
 

HU$H

New member
Ohhhhhh on the Animator Monitor Component. I just spent an hour looking for an Animator Monitor in Unity or trying to log events from the Animator lol. I forgot you have a component named Animator Monitor. Ok looking into this now
 
Last edited:

HU$H

New member
Okay, yes - after locating the Animator Monitor Component and enabling "Log Ability Parameter Changes" and "Log Events" I can see it fires the AbilityIntData change late, and fires no Events during a transfer process at all. Monitoring Nolan's events tho, he does not Log any Events either, but the AbilityIntData parameter changes faster than my characters does. Does this relate to a setting in my character prefab?
 

Justin

Administrator
Staff member
Thinking about it some more the problem may be related to your character's proportions. The hang ability determines that it is in position based on the In Position Shimmy Distance. When Unity retargets the animations for your own characters rig the transfer animation is likely moving a different amount than what it does for Nolan so that's why the animation has to repeat twice. If you increase the In Position Shimmy Distance value it should prevent the animations from playing twice, but for best results you'll want to replace the animations with your own that match the character's rig.
 

HU$H

New member
I love you with all my heart lol, that fixed it. The "In Position Shimmy Distance" was the issue so this is likely due to character proportions and rigging. I will replace most if not all of the animations but to start I am learning the controller inside out, building my own abilities etc. without spending as much time on things like animation. Although if I have an issue like this again (which I already do) I can make sure I edit the animation to work with my character. I have some animations for guns tho of course certain things have to be customized. Making sure my stack is solid first tho and that I can move through it gracefully as I build my first little game. Keep things clean. Really appreciate your time, thank you so much. Hopefully this will help someone else along the way dealing with similar issues with their character rig
 
Top