Dropped Item Can't be picked up

I can't pick up the first dropped item, i tried using dual pistols and can only pickup the second dropped item.

Here's a video showing the issue:


Staff member
Humm... this is just a guess but you may have a different drop prefab assigned depending if the pistol is on the right or left hand.
On the Item prefab check the Drop Prefab:

Make sure it references a prefab that does the pickup the integration way:
Thank you santi! I'll give it a try, the first part for sure was configured with the same drop prefab. I'll test the Item Sets
Still Not working, tried both solutions. It's persistent, even when i try with other objects, (same for other pickups), it won't pick them up and the ones it does pickup it gives this error:

Error: Unable to find the ItemSet for item 1 Rambo (3836566960) || ItemCollection Equippable (Secondary) || ItemStack(-939612672)[ 1 Rambo (3836566960) in ItemCollection Equippable (Secondary)] in category index 0. UnityEngine.Debug:LogError(Object) Opsive.UltimateCharacterController.Integrations.UltimateInventorySystem.UltimateInventorySystemBridge:OnItemActionEquipUnequip(ItemInfo, Boolean) (at Assets/Opsive/UltimateCharacterController/Integrations/UltimateInventorySystem/Scripts/UltimateInventorySystemBridge.cs:313) Opsive.Shared.Events.InvokableAction`2:Invoke(ItemInfo, Boolean) Opsive.Shared.Events.EventHandler:ExecuteEvent(Object, String, ItemInfo, Boolean) Opsive.UltimateCharacterController.Integrations.UltimateInventorySystem.CharacterEquipUnequipItemAction:InvokeActionInternal(ItemInfo, ItemUser) (at Assets/Opsive/UltimateCharacterController/Integrations/UltimateInventorySystem/Scripts/CharacterEquipUnequipItemAction.cs:70) Opsive.UltimateInventorySystem.ItemActions.ItemAction:InvokeAction(ItemInfo, ItemUser) (at Assets/Opsive/UltimateInventorySystem/Scripts/ItemActions/ItemAction.cs:97) Opsive.UltimateInventorySystem.UI.Panels.ActionPanels.ItemActionPanel:InvokeActionInternal(Int32) (at Assets/Opsive/UltimateInventorySystem/Scripts/UI/Panels/ActionPanels/ItemActionPanel.cs:66) Opsive.UltimateInventorySystem.UI.Panels.ActionPanels.ActionPanel`1:InvokeAction(Int32) (at Assets/Opsive/UltimateInventorySystem/Scripts/UI/Panels/ActionPanels/ActionPanel.cs:119) Opsive.UltimateInventorySystem.UI.Panels.ActionPanels.<>c__DisplayClass13_0:<OpenInternal>b__0() (at Assets/Opsive/UltimateInventorySystem/Scripts/UI/Panels/ActionPanels/ActionPanel.cs:69) Opsive.UltimateInventorySystem.UI.CompoundElements.ActionButton:press() (at Assets/Opsive/UltimateInventorySystem/Scripts/UI/CompoundElements/ActionButton.cs:72) Opsive.UltimateInventorySystem.UI.CompoundElements.ActionButton:OnPointerClick(PointerEventData) (at Assets/Opsive/UltimateInventorySystem/Scripts/UI/CompoundElements/ActionButton.cs:123) UnityEngine.EventSystems.EventSystem:Update() (at C:/Program Files/Unity/Hub/Editor/2019.4.18f1/Editor/Data/Resources/PackageManager/BuiltInPackages/com.unity.ugui/Runtime/EventSystem/EventSystem.cs:377)


Staff member
I tested this in my project and I can't seem to reproduce the error.

Could you try the integration demo scene to see if you get the same error?
If you do have the same error in the demo scene, perhaps you do not have the latest version of UIS or UCC or of the integration.

If not, something must be off with your Items or character.
Try comparing your prefabs to the demo prefabs to see if you can find any differences in the way it is set up.

The things I would look at especially is the Item prefab, the "Unique Item Set" field in particular.
Also make sure that your character has the Item Sets setup correctly in the InventorySystemItemSetManager Inspector.

Look at the inventory, inventory bridge and item set manager components at runtime to see if you can find anything off with them.

I hope this helps you close in on the underlying issue