Animation transitions happening over and over again

EagleGamer15

New member
I have a different variation of that problem:
I set up my controller to use substates, so my movement animations transition from the "Any" node.
My transition conditions to start playing my movement animation are:

"AbilityIndex Equals 0"
"ForwardMovement Greater Than 0.01"

These things are all true on the first frame I start moving, and all still true on the 100th frame that I am moving, so the transition from the Any state to starting my movement animation keeps activating over and over again.

I tried looking into the Quick Start ability, but it didn't help because the AbilityIntData is 1 when it starts, when it ends, and every frame in between.

I watched the Animator Controller video a second time and didn't see anything I could use.

I tried analyzing the Demo scene controller, but none of my animations do anything with LegIndex (which is the only parameter I can tell is different and I'm still unsure of where or how it get set).

Do I have to make my own custom ability just to start playing my movement animation by forcing one of the other parameters to change, and then turning it off a frame or two later?
 

Sarah

Administrator
Staff member
Is your movement animation set to looping on the actual animation? If it isn't set to looping it will end and the transition will restart.

The demo controller uses several parameters to transition but they are not all necessary, you don't have to use LegIndex or Moving/Aiming.

Another thing that could be causes it is that two animations are true at the same time so it keeps switching between the two but it sounds to me like your animation is playing all the way through then restarting.

Hope this helps!
 

EagleGamer15

New member
All my movement animations are set to looping.

When I play the game and watch the animator (with Auto Live Link enabled) it doesn't finish a single loop of the movement animation before going to a new transition. The only other transition I have is to go to an idle pose, and that doesn't have any parameters, just to default when nothing else is true.

What I wound up doing was creating a new animator parameter, and using an AnimatorBehaviour to manually set it when the movement state starts, and that "fixes" the problem. It just feels like I'm missing an obvious chunk of how the UCC is supposed to work.
 

EagleGamer15

New member
I found the solution while looking for a fix to a differnt problem:
In the transition, under the Settings dropdown is an option to allow or prevent "Can Transition To Self". It worked as soon as I turned this off.
 
Top