A* Wander never reaching destinations

Nex

New member
I've been trying to get the A* Wander.cs script to do what it's supposed to do for the past 6 hours or so, i just can't get it to work and need serious help.

When setting the wander, it will wander once and then stop, i have added debugging to bits and pieces and the wandering gameobject never reaches the first point, it walks abit, then stops, anything between 5 to 18f away from the actual target.

Steps ive tried to fix this:
* Validate that the point we are trying to do is a node we can reach by various means.
* Pre-edit the destination vector by using AstarPath.active.GetNearest and use THAT vector instead.
* Try to programatically increase the tolerance threshold to 1f, 2f, 5f, for the acceptable distance but it's never enough as it has (so far) been able to break as far as 18f from the target.

Sometimes i've managed to get it to run twice (verified by logs) but it still doesn't move so i'm assuming this is because it actually pulls the same location again (why i don't know) so hence it's stuck at the same place.

Is there something obvious i'm missing because I'm running out of ideas. one would think a wander task would be rather trivial after getting AI player chasing working :S
 

Justin

Administrator
Staff member
I will be able to try this task tomorrow but does the demo scene work correctly for you?
 
Top